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Welcome to the Maxym Pattern Maker software program. This tool 
provides great flexibility in creating and managing machine patterns 
easily from your personal computer. Your CNC machine uses the 
patterns you create to cut or shape the products you design.

You draw and the robot cuts what you have drawn. It is as simple as 
that. Instructions embedded in the pattern lines tell the robot how fast 
and how deep to cut. The Pattern Maker software also imports DXF 
and additional pattern files from other drawing or computer-assisted 
drawing programs. This makes Pattern Maker compatible with a wide 
range of programs in the CNC and CAD field.

The program is designed to be easily learned, while offering unusual 
flexibility and power. Use it to design a simple two-dimensional 
pattern or a complex three-dimensional shape.

This flexibility and ease of use make the Maxym Pattern Maker 
software ideal for all jobs, ranging from the development of prototype 
products, to full-scale production work.
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Using this manual

This manual provides detailed 
instructions designed to get you 
started creating patterns 
immediately. It also includes a 
description of how various 
machines interpret the pattern data.

This manual assumes you have a 
basic knowledge of the Windows 
operating systems.

This manual begins with a 
description of the software working 
environment, the drawing and menu 
tools used to create patterns, and 
how to specify pattern line 
properties.

The remainder of the manual 
describes machine controls and 
drawing techniques.

Styles used in this manual

This manual uses different type 
styles to explain the use of the 
Pattern Maker software. These 
styles are followed throughout the 
manual to help make learning the 
software easier.

Bold type
The names of menus, commands 
and buttons are in bold type.

Buttons
The word button indicates an 
on-screen box that performs a 
function or displays a menu when it 
is selected.

The word button also refers to the 
pc mouse buttons.

Submenus
When a reference is made to a 
submenu found within another 
menu or button, the path to the 
submenu is indicated by a >.

For example, Transform > 
Disconnect indicates the 
Disconnect command is found 
under the Transform menu.

Dialog boxes
A dialog box refers to a window that 
pops up on screen following a 
command or action. Dialog boxes 
present information or offer more 
options within a given function. 

Keyboard
When a reference is made lo a 
particular keyboard command, the 
key combination necessary for that 
command is indicated in 
parenthesis.

For example, to view handles on 
patterns, turn on the handle control 
(H).
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Screen cursor
The term screen cursor indicates 
the arrow, pointer or tool cursor 
appearing on the computer screen.

User actions
The following words are used 
consistently throughout the manual:

Select: Indicates use of the Enter 
key or the left mouse button.

Cancel: Indicates use of the Esc 
key or the right mouse button.

Hold: Indicates holding a mouse 
button down without releasing.

Click: Means to press the mouse 
button once and release it.

Note
A Note denotes a helpful hint or 
important piece of information 
about the current subject.

System requirements

The Pattern Maker software 
requires an IBM-compatible 
computer. The minimum system 
requirements are:

• Pentium II (or equivalent) or 
higher microprocessor

• Windows 95 or higher
• 32 MB of RAM
• Standard 2 button mouse

Note
You may use any 
Windows-compatible pointing 
device such as a track ball or 
drawing tablet.

Setting up the system

Installing the software
• Close any open programs 

running on Windows.
• Insert the Maxym diskette or 

CD-ROM into your drive.
• Select Run from the Start menu 

and browse for the file named 
“setup.exe” on the disk.

• Select the file “setup.exe.
• Select Open.
• Select Ok to launch the Maxym 

software installation program.
• Follow the instructions provided 

by the installation program.

Starting the software
To start the Pattern Maker Software, 
select the Pattern Maker Software 
Icon in Windows under Start > 
Programs > Maxym.

You may create a shortcut to the 
software on the Windows desktop 
by holding the control key and 
dragging the Pattern Maker 
Software icon from the Start menu 
to the desktop.
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The screen environment

Each time you launch the Pattern 
Maker software, the program opens 
a large window containing the 
workspace, menu and function bars 
listed below and shown in Figure 
2.1. 

These menus and bars are 
described in this section. 

• Windows Menu Bar
• Pointer Bar
• Drawing Tools Bar
• Transformation Bar
• Settings Bar
• Maxym Bar
• Status Bar
• Object and Statics
• Rulers - appear on the top and 

left of the workspace
You may choose to hide or display 
the various bars using options in the 
Windows’ View menu.

View menu
The view menu allows you to 
control how menu bars and tool 
bars are displayed, as well as 
workspace grid settings. A check 
mark next to any of the above 
menus or functions under the View 
menu indicates that the display is 
visible.

Workspace
The workspace is the large white 
area filling most of the window. You 
draw patterns in this area. The size 
of the workspace is 800 inches 
(width) x 800 inches (height). The 
absolute zero point (0, 0) is located 
in the very top left of the workspace 
window. Positive X is to the right 
and positive Y is down from the 
absolute zero point.

You may change your view of the 
workspace by zooming in and out of 
the workspace. See Drawing tool 
bar on page 18.

Workspace grid
A horizontal and vertical grid lies 
under the workspace. This grid can 
be used to help align objects in a 
pattern.

Use the keyboard arrow keys to 
move the cursor one grid space and 
place it on a grid point.

View > Grid allows you to set the 
workspace grid size and turn the 
grid display on or off.

Grid Size
The grid size default is 1 inch. You 
may set the grid size to any 
dimension between 800 inches and 
.005 inches.
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Grid snap
When the grid snap function is 
turned on, all tools set the 
beginning and end point of an 
object at an intersecting grid point.

With grid snap on, you can see the 
screen cursor jump from grid point 
to grid point as you draw objects

Turn the grid snap on or off using 
the Snaps > Grid Snap function or 
by hitting the G key.

Windows’ menu bar
The Windows menu bar appears on 
the top of the window. Various 
Windows and Pattern Maker 
software functions are accessed 
through the menu bar.

The title of the pattern file appears 
above the menu bar.

Figure 2.1  The workspace window

Menu bar

Rulers

Transformation bar

Pointer bar

Settings bar

Maxym bar

Workspace

Drawing tools bar

Status bar
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Pointer bar
The pointer bar appears on the right 
side of the workspace. This bar 
contains the zoom, select and 
information cursors.

The pointers are explained in detail 
in Pointer tool bar on page 15.

Drawing tools bar
The drawing tools bar appears on 
the right side of the workspace. The 
drawing tools create and adjust 
patterns in the workspace. These 
tools are explained in detail in 
Drawing tool bar on page 18.

Transformation tools bar
The transformation bar appears to 
the right of the pointer bar. The tools 
in this bar move, rotate and flip 
objects in the workspace. These 
tools are explained in detail in 
Transformation tool bar on page 25.

Settings bar
The settings bar appears under the 
workspace. Relative and absolute X 
and Y distances are shown here, as 
well as the length and angle used to 
draw objects.

You may enter values in this menu 
when drawing objects.

Selection tolerance
The settings bar contains the 
selection tolerance adjustment. This 

controls the cursor sensitivity - how 
close the cursor needs to be to an 
object in order to select it. Increase 
the selection tolerance by sliding 
the bar to the right. Decrease by 
sliding to the left.

Maxym bar
The Maxym bar appears under the 
line information bar and displays the 
line depth, cutting speed, line type 
and I/O switches. 

This bar also has buttons to open 
the property settings for pre-defined 
and special line types. The Maxym 
bar controls are described in detail 
in Maxym bar on page 49.

Status bar
The status bar appears under the 
Maxym bar and lists the origin point, 
zoom level, drawing grid, snap 
status and mouse scroll.

Objects and statics
Objects and statics appear on the 
left side of the workspace when set 
to display in the View menu. This 
window lists the total number of 
layers, vectors, objects and 
individual types of objects used in 
the current pattern. 

Rulers
Rulers show dimensions in inches 
along the top and left side of the 
workspace.
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Using the pc mouse

Your pc mouse is the primary tool 
used to create patterns. You only 
need a two-button mouse. 
However, the software recognizes 
the third scroll wheel on some three 
button mouses. See Mouse scroll 
(third wheel button) on page 6.

Throughout this manual, buttons 
are referred to as left and right 
mouse buttons and the mouse 
scroll button (found on some 
three-button mouses).

The left and right mouse buttons 
have equivalent keys on your 
keyboard. Refer to Keyboard input 
on page 8 for a complete list of your 
keyboard commands.

Left mouse button - Select 
(Enter)
The left mouse button is used for 
selecting objects, or menus, or for 
indicating the position of objects to 
be placed on the screen. It is also 
used to set the beginning and end 
points when drawing a line or 
object. The Enter key on the 
keyboard has the same function as 
the left mouse button in the 
workspace. 

All Pattern Maker menus are 
opened by clicking once with the 
left mouse button. The left mouse 
button is also used to create a box 

that selects portions of a pattern. 
This selection box is created by 
clicking and holding the left mouse 
button while dragging the mouse. 
When the box is the proper size, 
release the button The pattern lines 
enclosed by the box are selected. 

Right mouse button - Cancel 
(Esc)
The right mouse button is used to 
deselect objects. It is also used to 
complete a drawing operation or 
function.

Clicking the right mouse button 
once while using a tool deselects 
any selected objects and leaves the 
tool active.

Clicking the right mouse button 
twice cancels an operation or 
function and brings up the selection 
cursor.

When the selection cursor is the 
active cursor, clicking the right 
mouse button with the arrow on the 
workspace opens a shortcut menu 
to various workspace functions.

The Esc key on the keyboard has 
the same function as the right 
mouse button.

Mouse scroll (third wheel 
button)
The mouse scroll button wheel 
included on some mouses is 
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recognized by the Pattern Maker 
software. This button is usually 
located between the left and right 
mouse button. Click this button to 
switch between three mouse 
scrolling modes:

•  zoom - increases or decreases 
magnification of workspace 
view

• vertical - moves workspace 
view up or down

• horizontal - moves workspace 
view left or right

The current mouse scroll mode is 
indicated in the status bar (see 
Status bar on page 5).

Roll the mouse scroll button to 
change your workspace view 
according to the mouse scroll 
mode.

Mouse pan
Click and hold the mouse scroll 
button and drag the mouse to pan 
the workspace view. This allows 
you to move the workspace view 
up, down, left and right, regardless 
of mouse scroll mode.

Screen cursor types

There are eight types of screen 
cursors, shown in Figure 2.2.

Figure 2.2  Screen cursors

Arrow cursor
The arrow is the selection cursor. 
It is used to select lines and objects, 
drawing tools or function buttons. Its 
reference point is at the tip. See 
Arrow cursor on page 15.

Information cursor
The information cursor appears 
when you use the information 
cursor tool. See Information cursor 
on page 16.

Arrow cursor

Information cursor

Zoom cursor

Text cursor

Crosshair cursor

Move cursor

Rotate cursor

Scale cursor
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Zoom cursor
The zoom cursor appears when you 
zoom in or out of the workspace. 
See Zoom cursor on page 17.

Text cursor
The text cursor appears when you 
use the notes tool. See Notes on 
page 25.

Crosshair cursor
The crosshair cursor appears when 
you use the drawing tools. The line 
points are created in the center of 
the crosshair.

Move cursor
The move cursor appears when you 
use the move point function or you 
move the arrow cursor over the 
object reference point of a selected 
object. See Move Point on page 26 
and Move object on page 32.

Rotate cursor
The rotate cursor appears when 
you use the rotate tool. See Rotate 
on page 26.

Scale cursor
The scale cursor appears when you 
move the arrow cursor over a 
corner of the bounding box of a 
selected object. See Scale object 
on page 33.

Keyboard input

The keyboard is used to enter file 
names and numeric values. In 
addition, several keys have control 
functions: 

Zero point (space bar) 
The space bar switches the screen 
coordinates between absolute zero 
and relative zero modes.

Absolute zero is always the upper 
left-hand corner of the workspace. 
Relative zero is set by clicking 
space bar anywhere on the 
workspace. In the relative zero 
mode, the X and Y coordinates 
displayed in the line information bar 
are measured from this relative zero 
point.

The relative zero point is shown on 
the screen by the marker shown in 
Figure 2.3

Figure 2.3  Relative zero point 
marker
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If a relative zero point is set, clicking 
the space bar again removes it.

For more information, see X and Y 
coordinate boxes on page 10. 

Select (Enter)
The Enter key has the same 
function as the left mouse button 
in the workspace. See Left mouse 
button - Select (Enter) on page 6.  
Enter is also used to complete the 
input of a parameter in the 
information section.

Multiple select (shift)
The Shift key allows you to select 
multiple objects with the left mouse 
button. 

Delete
The Delete key deletes selected 
objects in the workspace.

Backspace
Backspace deletes characters 
(when using the Notes tool) or 
numbers in coordinate boxes.

X - lock/unlock (X)
The X character key locks the 
cursor's X-axis movement, allowing 
only Y axis movement. Pressing X 
again unlocks the cursor. 

Y - lock/unlock (Y)
The Y character key locks the 
cursor's Y-axis movement, allowing 

only Y axis movement. Pressing Y 
again unlocks the cursor.

Switch cursor to keyboard 
inputs (Tab)
The Tab key allows you to enter 
coordinates in the settings bar 
coordinate boxes. This moves 
control of the cursor from your 
hand-held device to the keyboard.

Pressing Tab once activates the 
X-coordinate box (the text in the 
box becomes highlighted). Pressing 
Tab again moves to the next 
coordinate box. Repeating this 
process cycles you through all of 
the coordinate boxes and 
eventually returns the cursor to the 
screen.

Note
Entering coordinates with the Tab 
function locks X and/or Y cursor. 

Handles - on/off (H)
Handles are small boxes appearing 
at the end of each line in the 
workspace.

The H key turns the handles on 
(visible) or off.

The Draw > Handles function also 
turns handles on or off.
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Grid snap
The G character key turns the grid 
snap control on and off. See Grid 
snap on page 4.

Point snap
The P character key turns the point 
snap control on and off. The point 
snap forces the cursor to move to 
the nearest object point. 

This function may also be turned on 
or off using the Snaps > Point 
Snap.

Arrow keys
The arrow keys allow you to move 
the screen cursor in the X and Y 
axes. Each time you press an arrow 
key, the cursor moves one grid 
space in that direction. Using the 
arrow keys locks the cursor. The 
amount of movement can be 
controlled by changing the grid size 
in the system variable box.

X and Y coordinate boxes

Absolute coordinates (World 
Coordinates)
The X and Y coordinate boxes in 
the settings bar indicate the cursor's 
position from the absolute zero 
point, as long as a relative zero 
point has not been set using the 
space bar. Refer to Zero point 
(space bar) on page 8.

As discussed earlier, absolute zero 
is the upper left-hand corner of the 
workspace. This point does not 
change. When drawing in the 
absolute zero mode, coordinates in 
the X and Y coordinate boxes are 
measured from that corner.

The Rx and Ry coordinates indicate 
the distance from the last entered 
vector beginning point to the current 
cursor position.

Figure 2.4 shows the difference 
between relative coordinates when 
the relative zero point is set (top 
example) or not (bottom example). 

Relative coordinates
The X and Y coordinate boxes 
indicate the cursor distance from 
the relative zero point if a relative 
zero point is set with the space bar. 
Refer to Zero point (space bar) on 
page 8.

The Rx and Ry coordinates indicate 
the distance from the last entered 
vector beginning point to the current 
cursor position.

The relative zero point can be set 
anywhere on the workspace, as 
often as you want.

Relative zero is used to measure 
the various sections of a pattern or 
to measure between the various 
sections of a pattern.
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Figure 2.4  Coordinate boxes

Figure 2.4 shows the difference 
between relative coordinates when 
the relative zero point is set (top 
example) or not (bottom example).

In the top example, X and Y are 
measured from the relative zero 
point.

In the bottom example, X and Y are 
measured from the absolute zero 
point as a relative zero point has not 
been set. 

Lines

Colors
The Pattern Maker program uses 
color to display certain line 
characteristics. These include 
whether the line is selected or 
unselected, whether it is a part of a 
pattern or a guide line. The line 
colors are not interpreted by the 
CNC machine.

Blue - selected lines
A blue line is active, or selected.

If you change tools while drawing, 
or begin drawing a new line, the line 
or object automatically attaches to 
the end of the last selected line.

All draw menu functions (except 
group) act only on selected lines. 
Thus, if you want to rotate, flip, 
copy, or move a line, it must be 
selected.

Red - new lines
A red line is a line in the process of 
being drawn. Red lines change to 
blue lines once an end point is 
entered.

Black - deselected lines
Black lines are inactive, or 
deselected.

To deselect a selected line, cancel 
(right mouse button) while the 

Relative Coordinates

Absolute Coordinates
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screen cursor is in the workspace. 
The line turns black.

New lines do not attach to 
unselected lines.

Layers

Layer menu
The layer menu allows you to 
create and manage multiple layers 
in the pattern file.

Using layers allows you to see parts 
of your pattern with or without other 
parts of the pattern.

Another good use of layers is to 
separate different tool size 
compensations when you have tool 
changes. When you tool 
compensate a pattern, a new layer 
is automatically created with the 
tool size attached to it. This lets the 
machine know there is a tool 
change if the size is different 
between two or more layers

New Layer
Layer > New Layer creates a new 
layer in the current pattern file.

Merge Layer
Layer > Merge Layer combines 
selected layers into one layer. To 
select multiple layers, click the left 
mouse button while holding the 
ctrl key. To select all layers 
between two layers, click the left 

mouse button while holding the 
shift key.

Layer Dialog
Layer > Dialog displays the layer 
dialog box. The layer dialog box 
displays the layers and allows you 
to add, merge and delete layers. It 
also allows you to turn the display of 
a layer on or off, by selecting the 
eye icon to the left of the layer.See 
Figure 2.5.

Double click with the left mouse 
button on the name of a layer to 
change its name.

Figure 2.5  Layer Dialog Box 
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Save Active Layer
Layer > Save Active Layer

Layer > Save Active Layer saves 
the contents of the current layer in a 
new pattern file.

Load New Layer
Layer > Load New Layer loads all 
layers from a saved file into your 
current pattern. Any loaded layers 
containing the same name as a 
layer in the current file will have a 
number added to their name.
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Overview

The Pattern Maker software 
contains fourteen drawing tools and 
more than a dozen functions for 
manipulating patterns and lines. 
When used together, these features 
give you a wide range of options for 
designing products to be 
manufactured by a CNC machine.

The drawing tools are found on the 
right side of the Pattern Maker 
software window.

This chapter discusses each of the 
drawing tools and functions and 
how they are used.

Pointer tool bar

The pointer tool bar contains three 
cursor tools, the arrow cursor, the 
information cursor and the zoom 
cursor.

The pointer tool bar is shown in 
Figure 3.1.

You may move the pointer tool bar 
anywhere in the software window 
by clicking the left mouse button 
on, and dragging the tool bar 
handle.

Figure 3.1  Pointer tool bar

Arrow cursor
The arrow cursor selects objects. To 
select an object, position the cursor 
over the object and click the left 
mouse button. To select multiple 
objects, hold the shift key while 
clicking the left mouse button over 
the objects.

You may also select multiple objects 
by clicking the left mouse button 
and holding it while you drag the 
cursor to create a box around 
multiple objects. All objects in this 
box become selected.

Select matching objects
You may use the arrow cursor to 
select all objects with matching 
vector properties.

To select matching objects:

• Select the arrow cursor.

Arrow cursor

Information cursor

Zoom cursor

Handle
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• Hold ctrl while selecting an 
object. This launches the match 
selection dialog box.

• Click OK to select all objects with 
matching properties to those of 
the selected object.

or
• Define the vector properties for 

the objects you wish to select in 
the match selection dialog box 
and click OK to complete the 
selection of the matching objects. 

Information cursor
The information cursor allows you 
to view or modify vector properties 
of selected objects.

Note
This tool may be used on selected 
or unselected lines. 

Viewing object vector 
properties
To use the line information cursor to 
view object vector properties:

• Select the line information cursor.
• Move the cursor over the object 

and select. This opens the vector 
information dialog box.

While in the vector information 
dialog box, you may also set the 
current line settings for new objects 

to those of the selected object. See 
Figure 3.2.

Modifying object vector 
properties
To use the line information cursor to 
modify object vector properties:

• Select the line information cursor.
• Move the cursor over the object 

and select while holding the ctrl 
key. This opens the modify vector 
dialog box.

Use the modify vector dialog box, to 
edit the line type, z-depth, speed, 
line display type and I/O settings of 
the selected object(s). Use the 
check boxes in the bottom of the 
dialog box to edit a selected object, 
any objects with the same 
properties as the selected objects, a 
group of selected objects, or all 
objects at the same time. You may 
also choose to modify all vectors in 
the pattern that match those of the 
selected object, or all vectors in the 
pattern.

If you use the information cursor 
while multiple objects are selected, 
you may also choose to modify all 
selected vectors according to the 
settings you enter in the modify 
vector dialog box. See Figure 3.3.

Machining > Edit Vector also 
opens the modify vector properties 
dialog box.
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Figure 3.2  Vector information dialog box

Figure 3.3  Modify vector dialog box

Zoom cursor

The zoom cursor changes the 
workspace view by increasing or 
decreasing the magnification of the 
workspace. The maximum zoom 
displays 250 inches (width) of the 
workspace. The minimum zoom 
displays 800 inches (width) of the 
workspace.

To use the zoom cursor:

• Select the zoom cursor tool.
• Click the left mouse button over 

the workspace to zoom in one 
zoom increment (2 x the current 
zoom percentage).

• To zoom a selected workspace 
area, click and hold the left 
mouse button and drag the 
cursor to create a box. Release to 
zoom as close as possible to this 
selected area.

• Hold ctrl and click the left mouse 
button over the workspace to 
zoom out one zoom increment 
(1/2 of the current zoom 
percentage).

View > Zoom
View > Zoom also allows you to 
zoom in or out of the workspace 
view using one of seven specified 
zoom settings.
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Drawing tool bar

The Pattern Maker drawing tools 
allow you to draw straight, angled 
and free-form lines; arcs; circles; 
squares and ellipses. Some of the 
tools have more than one function.

The tools are activated by selecting 
them. This causes the screen 
cursor to change from a pointer to a 
crosshair. After selecting the tool, 
place the crosshair on the 
workspace where you want to begin 
drawing, click once and release. 
This begins the drawing operation. 
As you move the cursor, the tool 
creates the type of line selected. 
The drawing tools are shown in 
Figure 3.4.

You may move the drawing tools 
bar anywhere in the software 
window by clicking the left mouse 
button on, and dragging the tool bar 
handle.

The Draw menu in the Windows 
menu bar also allows you to choose 
one of the drawing tools included in 
the Drawing Tools Bar.

Figure 3.4  Drawing tools

Line

The line tool draws straight lines in 
the workspace. See Figure 3.5.

To draw a straight line: 

• Select the line tool.
• Move the crosshair cursor to the 

workspace. Select again to set 
beginning of the line.

• Move the cursor in the direction 
you want to draw.

• Select again to set the line point.
• Move the cursor and select again 

to draw another line or use 
cancel to end the operation or to 
change drawing tools. 

Notes

Line

Right angle line

Handle

Rectangle

Arc

Circle

Ellipse
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Note
As you draw the line, its length 
and angle are displayed in the line 
information bar. You can enter 
dimensions in these boxes to 
create the line by moving to the 
boxes with the mouse or by hitting 
the tab key.

Press enter after entering the 
values to complete the line.

Figure 3.5  Using the line tool

Note
You may hold ctrl while pressing 
the right mouse button to delete 
the last drawn segment when 
using the line tool. Repeat to 
continue deleting segments in the 
line

Right angle line
The right angle line tool draws lines 
at right angles to the absolute 
coordinates.

To draw a right angle line.

• Select the right angle line tool.

• Move the crosshair cursor to the 
workspace. Select again to set 
beginning of the line.

• Move the cursor in the direction 
you want to draw.

• Select again to set the line point;
• Move the cursor and select again 

to draw another line or use 
cancel to end the operation or to 
change drawing tools. 

Note
As you draw the line, its length 
and angle are displayed in the line 
information bar. You can enter 
dimensions in these boxes to 
create the line by moving to the 
boxes with the mouse or by hitting 
the tab key.

Press enter after entering the 
values to complete the line.

Figure 3.6  Using the right angle line 
tool
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Rectangle
The rectangle tool draws squares 
and rectangles.

To use: 

• Select the rectangle tool.
• Move the screen cursor to the 

workspace and select to set the 
starting point.

• Move the cursor to draw the 
rectangle.

• Select again to complete the 
rectangle and end the drawing 
operation.

Note
As you draw the rectangle, its 
length is displayed in the line 
information bar. You may enter 
dimension a dimension in the 
length box to to create a square by 
moving to the boxes with the 
mouse or by hitting the tab key.

Press enter after entering the 
values to complete the square.

Rectangles are drawn according to 
the mouse movement after the 
beginning point is set.

Figure 3.7 shows how to create 
rectangles in four different 
directions. Box A is created by 
pulling the cursor up and to the left. 
Box B is created by pulling the 

cursor up and to the right. Box C is 
created by pulling the cursor down 
and to the left. Box D is created by 
pulling the cursor down and to the 
right.

Figure 3.7  Rectangle vector 
directions

The direction in which the rectangle 
is created determines the direction 
of the CNC machine arm The 
starting point of each rectangle is 
indicated by the small black square. 

Figure 3.8  Using the rectangle tool

Circles
The circle tool draws circles. The 
circle shape can be created either 
by the by the length of each side in 

A

C

B

D
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the circle, or by the angles used to 
create these lines. This is done by 
changing the circle variables in the 
line information menu. 

To use: 

• Select the circle tool.
• Select one of the three circle 

types shown in Figure 3.9.

Center-to edge circle sets the 
center of the circle first, then 
draws the circle according to the 
radius set by the cursor.

Note
The start point of a center-to-edge 
circle forms at the end of the last 
selected line in a drawing (if no 
objects are selected, it starts 
where you set the starting point). 
The circle itself, however, does not 
attach to the line. It is a separate 
object unless it is tied with a tie 
line. 

Edge-to-center circle sets a 
perimeter point first, then draws 
the circle according to the radius 
set by the cursor. The cursor 
appears in the center of the circle 
while setting the radius.

Three point circle sets a 
perimeter point first, then draws 
the circle according to the radius 
set by the cursor. The cursor 

appears on another perimeter 
point of the circle while setting the 
radius.

Note
There is no difference in the circle 
drawn using these three circle 
types. They only offer three 
different methods to create circles.

Figure 3.9  Circle types

• Move the cursor to the workspace 
and select. This sets the center 
or perimeter point (depending on 
the tool) of the circle.

• Move the cursor away until the 
desired size of the circle is 
reached and select to set the 
circle and end the drawing 
operation.

The radius of the circle is listed in 
the settings bar.

Circle to edge

Center to point Three point
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Note
Circles are drawn in the direction 
of the cursor following the setting 
of the center or perimeter point. 
The beginning and ending points 
are located where you set the final 
point of the circle. 

Note
A circle may be flipped in a variety 
of directions to reverse its 
direction. See Flip on page 27.

Circle settings - by angle or 
length
The circle settings in the line 
information menu controls how the 
circle, arc or ellipse is drawn. The 
Pattern Maker software uses a 
series of straight lines (vectors) to 
draw objects, including circles and 
arcs.

The software allows you to control 
either the length of the lines that 
make up a circle, or the angles used 
to create the lines that make up the 
circle.

Note
You can enter a dimension in the 
radius box in the line information 
bar to draw the circle after setting 
the start point. Move to this box 
with the mouse or by hitting the 
tab key.

Press enter after entering the 
value to complete the circle.

Circles by length
The circle by length function allows 
to set a value limiting the circle 
sides to a length from .001" to 60". 
Shorter line lengths create a 
smoother circle. This also increases 
the number of sides in a circle, 
adding greatly to the memory load 
on the computer.

The number of sides in the circle 
varies depending on the size of the 
circle (larger circles contain more 
lines). 

To set the circle parameters to 
length, select the By Length 
button, enter the length of each side 
and press Enter. 

Circles by angle
The circles by angle function allows 
you to set the angle between the 
two rays drawn from the center of 
the circle to the end points of one of 
the line segments (sector) used to 
represent the final circle.

Smaller angles create a smoother 
circle. This also increases the 
number of sides in a circle, adding 
greatly to the memory load on the 
computer.

The maximum angle is 120 
degrees, since this makes a 3-sided 
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triangle. An angle greater than 120 
degrees only forms two 
unconnected lines or a distorted 
triangle.

To set the circle parameters to 
angle, select the By Angle button, 
enter the angle and press Enter.

Figure 3.10  Using the circle tool

Arc
The arc tool draws arcs from 1 to 
360 degrees.

If no lines are selected on the 
screen, the arc begins at the point 
you select with the screen cursor. 
The arc forms in the direction in 
which you drag the cursor after 
setting the starting point.

If an object is already selected 
when you begin drawing the arc, 
the arc begins at the end of that line 
and sweeps toward the cursor 
point. Thus, if the cursor is to the 
right of the line, the arc attachs to 

the end of the line and sweeps to 
the right.

To create an arc:

• Select the arc tool.
• Move the screen cursor to the 

workspace.
• Select to set the beginning point. 

If an object is already selected, 
the beginning point of the arc is 
the last drawn point in the 
selected object.

• Set the direction of the arc sweep 
by dragging the cursor to the left 
or right.

• Move the cursor to the desired 
arc radius and select to set the 
radius.

• Drag the mouse to adjust the arc 
angle and select to set the arc. 
This also ends the drawing 
operation.

Note
You can enter exact values for the 
arc radius and angle in the line 
information bar.

Figure 3.11 shows the parts of an 
arc sweeping to the left.
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Figure 3.11  Parts of an arc

Arc settings - by angle or length
Arc settings for angle or length are 
similar to those for circles. Refer to 
Circle settings - by angle or length 
on page 22.

Ellipse
The ellipse tool draws ellipses. It 
works in a similar manner to the 
circle tool. 

To use: 

• Select the ellipse tool.
• Move the screen cursor to the 

workplace.
• Select to set center of ellipse.
• Drag the cursor to form the 

ellipse.
• Select to set the ellipse when the 

ellipse is the proper size. The 
diameters in the X and Y axes are 
displayed in the line information 
menu.

Note
The center of an ellipse forms at 
the end of the last selected line in 
a drawing. The ellipse itself, 
however, does not attach to the 
line. It is considered a separate 
object unless it is tied with a tie 
line. 

Note
The reference point is located in 
the center of the ellipse. The 
beginning and ending point is 
wherever the cursor is when you 
select to set the end point. 

Figure 3.12 shows an ellipse with its 
reference point in the center. The 
direction of an ellipse is always 
created in a counter-clockwise 
direction.

Figure 3.12  Using the ellipse tool

Note
An ellipse may be flipped in a 
variety of ways to reverse its 
direction. See Flip on page 27.

Angle

Radius

Beginning
point
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Ellipse settings - by angle or 
length
Arc settings for length or angle are 
similar to those for circles. Refer to 
Circle settings - by angle or length 
on page 22.

Notes
The notes tool adds text to the 
pattern. This text only appears on 
the screen for your reference. It 
does not affect the pattern.

To use the notes tool:

• Select the notes tool.
• Move the screen cursor to the 

workspace.
• Select to set the starting point.
• Enter the text.
• Select again to end the drawing 

operation.

Transformation tool bar

Transformation tools allow you to 
change object shapes, sizes and 
orientations. Many of these tools act 
in relation to the object reference 
point, described in Object reference 
point on page 25.

The transformation tools are shown 
in Figure 3.13.

You may move the transformation 
tool bar anywhere in the software 
window by clicking the left mouse 

button on, and dragging the tool bar 
handle.

Figure 3.13  Transformation tool bar

Object reference point
Each object has a reference point. 
The object reference point is a red 
circle with a solid x, appearing when 
an object is selected. 
Transformation tools act on the 
object with respect to the object 
reference point.

Figure 3.14  Object reference point

The reference point is created in the 
center of the object, but it may be 
moved to another location in the 
workspace. 

Move point

Rotate

Flip vertical

Handle

Flip horizontal

Object reference point
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To move the reference point, move 
the cursor over the reference point, 
click and hold the right mouse 
button and drag the reference point 
to a new location.

Release the right mouse button to 
set the reference point.

Move Point
The move point tool moves a point 
that already exists in a pattern, 
allowing you to reshape or resize 
existing objects. 

To use:

• Select the move point tool.
• Move the screen cursor to the 

point you would like to move.
• Select to grab the point.
• Move the cursor to the new point 

location.
• Select to set the point in the new 

location.

Note
If you cannot see points on lines in 
the pattern, the handle function is 
probably turned off. To turn it on, 
press H on the keyboard.

Figure 3.15 shows how the move 
point tool is used to move the right 
hand line point downward.

Note
You may also enter coordinates in 
the line information bar for the 
destination of a selected point 
when using the move function. 
Start to move the point then use 
the mouse or tab to enter the 
coordinate boxes. Type in the 
coordinates and hit enter to 
complete the operation.

Figure 3.15  Using the move point 
tool

Rotate
The rotate tool rotates an object 
about the object’s reference point. 
To use the rotate tool:

• Select an object in the 
workspace.

• Select the rotate tool.
• Move the cursor to the 

workspace.
• Move the object reference point if 

needed.
• Select to begin rotating the 

object.
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• Move the cursor to rotate the 
object about the reference point.

Note
The further away from the 
reference point you move the 
cursor, the more control you have 
in rotating the object.

• Select to complete the operation.
• Click the right mouse button to 

switch the cursor to the arrow, or 
select another drawing tool to 
finish using the rotate tool.

Note
You may also enter coordinates in 
the line information bar for angle 
of the rotation. Start to rotate an 
object then use the mouse or tab 
to enter the angle box. Type in the 
angle and hit enter to complete 
the operation.

Note
Holding ctrl while releasing the 
left mouse button creates a copy 
of the object in the new location 
and leaves the original object as 
is.

Figure 3.16  Using the rotate tool

Flip
The flip tool allows you to change 
the orientation of an item 180 
degrees by flipping it horizontally or 
vertically over the object reference 
point. 

Note
The flip tool can be used to create 
symmetrical items. You can draw 
half of the item, copy and flip it, 
then tie the two halves together to 
form a symmetrical whole. 

• Select an object in the 
workspace.

• Move the cursor to the 
workspace.

• Move the object reference point if 
needed.

• Flip the object by selecting the 
flip vertical or flip horizontal tool.

• Click either mouse button to 
switch the cursor to the arrow, or 
select another drawing tool to 
finish using the flip tool.
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Figure 3.17 shows the horizontal 
flip.

Figure 3.18 shows the vertical flip.

Note
Holding ctrl while releasing the 
left mouse button creates a copy 
of the object in the new location 
and leaves the original object in its 
location.

Figure 3.17  Flip horizontally

Figure 3.18  Flip vertically

Transform menu
The Transform Menu provides 
another way to choose functions 
included in the Transformation Bar, 
as well as additional functions. The 
functions listed under the Transform 
Menu include:

• Move point
• Horizontal flip
• Vertical flip
• Rotate
Reverse
Transform > Reverse reverses the 
direction of vectors in an object.

Before flip

After flip

Before Flip

After flip
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Manipulate Z
Transform > Manipulate Z allows 
you to modify the Z values of a 
selected group of objects. This 
provides even more flexibility in 
creating 3D patterns. The 
Transform > Manipulate Z dialog 
box is shown below.

Figure 3.19  The manipulate Z 
function

Transform > Manipulate Z 
modifies Z values in the following 
three ways:

• Addition to Z
• Gradual addition to Z
• Inverse around Z reference
Addition to Z
Addition to Z adds the Z amount 
you specify in the “Z Reference” 
box to each of the existing Z values 
of the selected objects in a group. 
You may enter a positive or 
negative number using this 
function.

For example, if you select a group 
of objects, each with a Z value of 1, 
and you set the “Z Reference” to 
.25, when applied using the 
Addition to Z function, the new Z 
values become 1.25.

Gradual addition to Z
Gradual addition to Z applies the 
total amount of the Z value you 
enter in the“Z Reference” box 
gradually to each object in the 
selection, according to the 
sequence of the objects.

For example, if you selected 4 
objects and you specified the “Z 
Reference” as 1, a value of 0 would 
be applied to the first object, a value 
of .25 to the second, a value of .5 to 
the third, and a value of .5 to the 
fourth.

Inverse around Z reference
Inverse around Z reference 
creates a “mirror image” of the Z 
values for a selected group of 
objects. The “Z Reference” value 
you enter in the dialog box is the Z 
value of the object which you want 
to be the reference point for the 
inverse transformation.

For example, if you have drawn a 
pattern to create a 3D model of a 
person’s face, you could use this 
function to change the pattern to 
create a mask of this face. You 
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would do this by selecting the 
objects in the pattern and entering 
the highest Z value in the pattern as 
the “Z Reference” when performing 
this transformation.

Scale offset
Transform > Scale Offset resizes 
the vectors of a selected object by 
recreating them parallel to their 
original location and offset to the left 
of right of the vector according to 
the distance you specify. 

To use the Transform > Scale 
Offset function:

• Select the object(s) you want to 
scale offset.

• Select Transform > Scale 
Offset.

• Enter the size of the offset and 
the side of the vector for the offset 
to occur.

• Click the OK button.
• Select to complete the operation.

Connect
The Transform > Connect function 
connects separate, selected objects 
in the workspace in two ways, 
directly or displaced. The individual 
objects become one object using 
this command.

To connect objects, first select the 
objects then choose one of the 
following connect methods:

Transform > Connect > Directly 
moves lines and objects together to 
make them one object. Objects are 
connected in sequence, either the 
order in which they were drawn, or 
the order in which they were 
sequenced.

The function leaves the first 
sequenced object in its original 
location and moves the other 
objects to connect the end point of 
the earliest sequenced object with 
the start point of the next object. 
Figure 3.20 shows two objects 
connected directly. The arrows in 
the figure indicate the order and 
direction in which the objects were 
drawn.

For information on sequencing, see 
Sequencing Objects on page 46.
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Figure 3.20  The connect directly 
function

All objects except the first 
sequenced object move from their 
original location when connected 
with the Transform > Connect > 
Directly function.

If Transform > Connect> Directly 
is used when there are selected 
objects on the workspace, only 
those selected objects are 
connected. If no objects are 
selected, Transform > Connect> 
Directly connects all objects on the 
workspace.

To connect objects using the 
Transform > Connect> Directly 
function:

• Select the lines or objects you 
want to connect directly.

• Select Transform > Connect > 
Directly.

The program moves the objects 
to connect them as one object. 

Transform > Connect > Displaced 
creates one object out of several by 
drawing pattern lines from the end 
point of an object to the start point 
of another. Items are connected in 
sequence, either the order in which 
they were drawn, or the order in 
which they were sequenced.

This function works on selected 
objects or all objects if none are 
selected.

All of the objects remain in their 
original location. Figure 3.21 shows 
two objects connected directly. The 
arrows in the figure indicate the 
order and direction in which the 
objects were drawn.

For information on sequencing, see 
Sequencing Objects on page 46.

Seperate objects

Connected objects (directly)

1 2



32323232

MAXYM

Figure 3.21  The connect displaced 
function

To connect objects using the 
Transform > Connect > Displaced 
function:

• Select the lines or objects you 
want to connect directly.

• Select Transform > Connect > 
Displaced.

The program draws pattern lines 
to connect the objects. 

Disconnect
Transform > Disconnect 
disconnects an object previously 
created from two or more objects 
using the connect function. Select 
the object then Transform > 
Disconnect to break the connected 
object into the original objects.

Note
The objects do not move to their 
original locations using this 
function.

This function works on selected 
objects or on all objects if none are 
selected.

Mouse functions

The Pattern Maker software allows 
you to perform various functions 
using the mouse.

Move object
The move object function moves 
objects in the workspace using the 
cursor and the object’s reference 
point.

To use the move function:

• Select an object in the 
workspace

• Move the object reference point if 
needed.

• Place the cursor on the reference 
point and hold the left mouse 

Seperate objects

Connected objects (displaced)

1 2



Drawing Tools and FunctionsDrawing Tools and FunctionsDrawing Tools and FunctionsDrawing Tools and Functions 33333333

MAXYM

button while dragging the object 
to the new location.

• Release the left mouse button 
to set the object in the new 
location.

• Select again to end the 
operation.

Figure 3.22 shows the how the 
move object function is used to 
move a rectangle up and to the left.

Figure 3.22  Using the move 
function

Note
You may also enter coordinates in 
the line information bar to specify 
the destination of the reference 
point when moving an object. Use 
the mouse or hit tab to enter the 
coordinate boxes. Enter the 
values and hit enter to complete 
the operation.

Note
Holding ctrl while releasing the 
left mouse button creates a copy 
of the object in the new location 
and leaves the original object in its 
location.

Scale object
The Scale function allows you to 
increase or decrease the size of an 
object or pattern. The change is 
measured as a percentage of the 
original size. 

To use the scale an object: 

• Select the object.
• Place the cursor on one of the 

corners of the bounding box of 
the selected object.

Note
The object’s corner box opposite 
to the one you select remains in 
the same place, while the others 
move accordingly with the scaling.

• Click the left mouse button and 
drag the box to scale the object. 
The scale change is displayed in 
the line properties menu. The 
numbers indicate the change in 
percentage in the X and Y 
dimensions.
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Note
You can lock the cursor in the X or 
Y axis once the desired 
percentage in that axis is reached. 
Then you can move the cursor in 
the other direction to obtain the 
second percentage. This is easier 
than trying to reach both 
percentages at the same time.

You can also hold the ctrl key 
while dragging the corner of the 
bounding box to scale the image 
proportionally, according to the 
longest scale value.

• Release the left mouse button 
to set the object to the new size.

Figure 3.23 shows how the scale 
function is used to make a rectangle 
larger.

Figure 3.24 shows an item scaled 
proportionately and 
disproportionately. 

The scale function allows you to 
change the size of items in the 
pattern, including objects created 
using the Transform > Connect 
functions.

Figure 3.23  Using the scale 
function

Figure 3.24  Proportional and 
disproportional scaling

Proportional scaling

Disproportional scaling
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Overview

This chapter discusses some 
techniques for efficient drawing and 
design. This chapter also discusses 
how to design patterns for some 
basic CNC machine functions, such 
as flat and three-dimensional 
cutting. 

Using numeric X and Y 
coordinates

There may be times when you use 
the Pattern Maker software to copy 
a pattern already designed on 
paper. You can use the cursor to 
trace the pattern, or you can enter 
the pattern coordinates directly into 
the program. 

This is more accurate and in some 
cases easier than using the cursor, 
particularly if you are copying a 
pattern that already has the 
dimensions marked on it. 

To enter the numeric coordinates for 
a drawing, use the Tab key to 
switch control of the cursor from the 
mouse to the keyboard. 

When you press the Tab key, the 
numerical value in the X 
coordinate box becomes 
highlighted. 

When the X coordinate box is 
highlighted, you may enter the 
numerical cursor coordinate for the 

X axis. Pressing the Tab key again 
moves you to the Y coordinate 
box.

Note
If you tab through a box without 
making an entry, the value 
remains unchanged. 

Each time you press Tab, the next 
input box in the settings bar 
becomes highlighted, allowing you 
to enter numerical values. Pressing 
Tab repeatedly continues to cycle 
through the input boxes.

Press Enter when you have 
completed entering numeric 
information. You will see the cursor 
jump to its new position. 

Note
Remember, when entering 
coordinates in the absolute zero 
mode, the program measures 
from absolute zero - the upper left 
hand corner of the workspace. 
Thus, if you enter an X coordinate 
of 10 and a Y coordinate of 20, the 
cursor moves to a position 10 
inches away from the left hand 
edge of the workspace and 20 
down from the top of the 
workspace. 



36363636

MAXYM

Note
If you enter an incorrect number in 
the coordinate box, press the 
right mouse button to delete the 
entry and return to the cursor. 

Note
Using the coordinate boxes locks 
the screen cursor in that particular 
axis. To unlock the screen cursor, 
press the X or Y key. See X - 
lock/unlock (X) and Y - lock/unlock 
(Y) on page 9. 

To measure from the cursor's 
existing position, you need to 
change to relative zero mode. To do 
this press the space bar once. This 
switches the program into relative 
zero and sets the current screen 
cursor position as 0,0. 

Note
If you are already in relative zero 
mode and want to create a new 
0,0 point, press the space bar 
twice. 

Note
When using numeric input to draw, 
it is easiest to lock the screen 
cursor before beginning the 
drawing. This blocks input from 
the cursor, preventing you from 
accidentally moving the screen 

cursor. See X - lock/unlock (X) and 
Y - lock/unlock (Y) on page 9. 

Examples using numeric 
coordinates
Drawing a 10-inch straight line
To draw a straight line using 
numeric coordinates:

• Select the straight line tool.
• Move the screen cursor to the 

workspace.
• Lock the cursor by pressing the X 

and Y keys.
• Select to set the beginning of the 

line.
• Set a zero point (press the space 

bar).

Note
Remember, you have to press the 
space bar twice if you are already 
in relative zero mode.

• Press Tab once to enter the 
X-coordinate box (the value in 
the box becomes highlighted). 

• Enter 10 in the box.
• Press Enter to draw the line. 
• Click the right mouse button to 

complete the drawing operation.
• Unlock the cursor by pressing the 

X and Y keys.
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Drawing a 10 by 20-inch box
To draw a box using numeric 
coordinates:

• Move the screen cursor to the 
point where you want to begin the 
box.

• Lock the cursor by pressing the X 
and Y keys.

• Select to set the corner of the 
box.

• Set a zero point (press the space 
bar).

Note
Remember, you have to press the 
space bar twice if you are already 
in relative zero mode.

• Press Tab once to enter the 
X-coordinate box (the value in 
the box becomes highlighted).

• Enter 10 in the box.
• Press Tab once to enter the 

Y-coordinate box (the value in 
the box becomes highlighted).

• Enter 20.
• Press Enter to draw the box. 
• Click the right mouse button to 

complete the drawing operation.
• Unlock the cursor by pressing the 

X and Y keys. 

Drawing circles 
Circles may be drawn in this same 
manner. Keep in mind that when 

drawing a circle, enter coordinates 
only in one box (it doesn't matter 
which). Also, when drawing a circle, 
enter the radius of the circle in the 
box, not the diameter. Thus, if you 
want a circle with a 10-inch 
diameter, you must enter 5 in the X 
or Y coordinate box. 

Drawing ellipses
Ellipses are drawn in the same 
manner as circles, except you must 
enter both an X value and a Y 
value. Like circles, these values are 
the radii for the completed ellipse. 

Changing line parameters

Once you have drawn a pattern on 
the screen, you can go back and 
change the parameters of one, all, 
or matching (to selected) lines. This 
is done using the information 
cursor. Refer to Modifying object 
vector properties on page 16.

There are several ways to change a 
line. You may change a single 
parameter on one line or several 
parameters and lines at once. 
When you change a single 
parameter, other parameters 
attached to the line(s) are not 
affected. 

Because each use of this function 
has different results, we will discuss 
each one separately. 
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Changing parameters on a 
single line
To change parameters on a single:

• Select the line you want to 
change.

• Open the modify vector 
properties dialog box (ctrl + 
information cursor).

• Select the “single” option under 
the “modify” category.

• Select the parameters you want 
to change.

• Enter the new parameters or 
select one from the menus that 
appear. In the case of Z-depth 
and speed changes, you enter a 
new value.* 

In the case of line type, select a 
new type from the menu that 
appears. In the case of an I/O 
change, select a new switch from 
the menu that appears.

• When you have entered the new 
parameters, select OK to 
complete the operation.

Changing parameters on a 
group of selected lines
To use the change line function to 
change parameters on a group of 
selected lines at one time:

• Select the line or lines you wish 
to change.

• Open the modify vector 
properties dialog box (ctrl + 
information cursor).

• Select the “selected” option 
under the “modify” category.

• Enter the new values*.
• When you have entered the new 

parameters, select OK to 
complete the operation.

All the line parameter information 
will now be attached to the selected 
lines.

Changing parameters on 
matching lines
To use the change line function to 
change parameters on all lines 
matching a particular line type.

• Select the line you want to 
change.

• Open the modify vector 
properties dialog box (ctrl + 
information cursor).

• Select the “matches” option 
under the “modify” category.

This allows you to change all 
lines exactly matching the 
selected line in every parameter: 
line pattern, Z- depth, speed, type 
and I/O selection. 

• Select the parameters you wish 
to change.

• When you have entered the new 
parameters, select OK to 
complete the operation.
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Changing parameters on all 
lines
To use the change line function to 
change parameters on all lines in a 
pattern.

• Open the modify vector 
properties dialog box (ctrl + 
information cursor) on any line.

• Select the “all” option under the 
“modify” category.

This allows you to change all 
lines in the pattern, in every 
parameter: line pattern, Z- depth, 
speed, type and I/O selection. 

• Select the parameters you wish 
to change.

• When you have entered the new 
parameters, select OK to 
complete the operation.

Simple drawing examples 

This section shows you simple 
drawing examples using specific 
pattern types.

Flat work 
Flatwork patterns are the easiest to 
design. When properly drawn, what 
you draw on the screen is what the 
CNC machine cuts.

Two-dimensional pattern 
Flatwork patterns are 
two-dimensional. They are 
designed using flatwork lines that 

have instructions for depth of cut 
(Z-depth) and speed of the CNC 
machine. 

Example: You want to use cut a 
Christmas-tree shaped ornament 
from 1/2-inch plywood. You have 
been given a pattern for the 
ornament that you will trace into the 
computer.

To begin, create a cutting line in the 
Maxym bar: 

• Set a pattern for the cutting line 
you will be using.

• Set the Z-depth.

This value is the sum of the 
following measurements: the 
distance you want the tool to 
remain above the workpiece as it 
travels between cuts (this is 
usually .5 inches); the thickness 
of the stock (in this case, it is .5 
inches); an extra amount to 
insure that the endmill completely 
penetrates the stock (this is 
usually .1 inches).
Adding these values together you 
get 1.1 inches for the Z-depth 
value.

• Enter the CNC machine speed.
• Set the line type.

Because this is a 
two-dimensional project, choose 
the flatwork line type (F)
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• Set the I/O control.

Because only the CNC machine 
router runs during this operation, 
select the first switch.

• Cancel to leave the Maxym line 
menu.

Now you are ready to draw.

Place the drawing of the ornament 
on the graphics tablet. Select the 
angled line tool and begin tracing 
the ornament's shape onto the 
workspace. As you trace the shape, 
select at each point in the pattern.

When you have completed tracing 
the ornament pattern and have set 
the final point, cancel to complete 
the drawing operation. Your pattern 
is complete. 

This pattern tells the CNC machine 
to begin cutting the pattern at the 
point you began drawing.* lt 
plunges the endmill into the stock, 
then follows the pattern lines until it 
reaches the end of the pattern. 
Once there it pulls the endmill from 
the stock, leaving behind the 
ornament. 

*This assumes you have positioned 
the CNC machine tool over the 
starting point of the pattern.

Using contours to produce 3D 
shape
You can instruct the CNC machine 
to cut a three-dimensional shape 
while using a two-dimensional 
drawing program.

This is accomplished by drawing a 
series of contours of the shape you 
want to produce using the X- or 
Y-contour lines.

The X- and Y-contour lines instruct 
the CNC machine to travel along 
one coordinate and to use the other 
to control the movement of the 
Z-head.

By cutting a series of contours over 
a block of material, you can 
produce a three-dimensional shape.

Example:

You want to produce a solid model 
boat hull from a block of maple. You 
do not have a drawing, but you do 
have a sample hull you want to 
reproduce. 

Using a contour gauge, get an 
impression of the hull's contour at 
intervals of 1/2 inch.

Trace each contour onto a piece of 
paper. When all the contours have 
been taken and traced onto paper, 
trace them into the computer using 
the line tool and a Y-contour line.
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Note
Draw each contour as a separate 
line.

Position the separate contours in 
the Y-axis (stacked one over 
another). Separate each by 1/2 
inch. 

When all the contours are aligned, 
tie them together using the 
Machining > Tie Line function.

When this pattern is run on the CNC 
machine, the arm follows each 
contour in the X-axis while 
interpreting Y-axis coordinates as 
Z-depth instructions.

The CNC machine head rises and 
falls along the contour line as the 
arm moves along the X-axis.

When the arm comes to the end of 
a contour, it follows the tie line to 
the beginning of the next contour 
and repeats the process.

When the pattern is completed, the 
three-dimensional shape of the boat 
hull will have been carved from the 
block of wood, one contour at a 
time.

Sloped-plunge lead-in carving
You can use the 3D line type to 
ease the router tool into the 
workpiece. This allows you to use a 
tool that lacks cutting surfaces on 

its bottom and thus cannot be 
plunged directly into the work.

To use this method, draw a 3D line 
that begins outside the pattern and 
ends at the beginning point of the 
pattern. The line's Z-depth should 
be set so that the tool will be in the 
proper position when it reaches the 
end of the 3D line.

When this line is run on the CNC 
machine, the arm follows the line 
into the workpiece, descending on a 
steady slope. This allows the tool to 
enter the workpiece gradually, at an 
angle.
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How the CNC machine 
interprets patterns

The Pattern Maker software is 
designed to control the movement 
of the CNC machine using lines 
drawn on the screen in a manner 
similar to that of most computer 
drawing programs.

A pattern is composed of a series of 
lines or vectors. Each vector 
denotes a direction and distance. It 
has a beginning and an ending 
point.

It is also important to note that a line 
drawn on the screen may actually 
contain several vectors. This 
manual describes how to do draw 
lines, arcs, circles, and squares. It 
is important to remember that all 
these shapes are made up of 
connected vectors.

Each vector also contains 
information to control how fast the 
CNC machine moves, how deep it 
cuts and what kind of cut it makes.

Anytime a line changes direction, a 
new vector is required 

Figure 5.1 shows vectors in a line 
and vectors in a square.

Figure 5.1  Vectors

Thus a square, which would appear 
to be a single line, is actually 
composed of four connected 
vectors. The same is true of a circle, 
which may contain thousands of 
connected vectors.

The X, Y and Z axes on the 
screen and CNC machine

The Pattern Maker software 
contains several different line types, 
each of which carries different 
instructions to the CNC machine. 
See Line types on page 52.

With the simplest line types (and 
the ones most commonly used) the 
CNC machine arm follows the line 
as an automobile driver follows a 
map.

Lines drawn on the X-axis 
(horizontal) cause the CNC 
machine arm to move left and right 

Vectors in a line

Vectors in a square
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across the cutting table. See Figure 
5.2.

Lines drawn on the Y-axis (vertical) 
cause the CNC machine arm to 
move forward and backward over 
the cutting table. See Figure 5.3.

Figure 5.2  X-axis machine 
movement

Figure 5.3  Y-axis machine 
movement

Z-depth instructions included in 
each line cause the CNC machine 
head to move up and down, in and 
out of the workpiece. See Figure 
5.4 

Figure 5.4  Z-axis machine 
movement

Information in a line 

Colors
The Pattern Maker software uses 
color to display certain line 
characteristics. These include 
whether the line is selected or 
unselected, whether it is a part of a 
pattern, a guide line or other type of 
line. The line colors are not 
interpreted by the CNC machine.

Lines on page 11 describes the 
object line colors in the workspace. 
The remainder of this section 

X-axis direction

Y-axis direction

Y-axis direction

Z-depth
direction
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describes the line types that affect 
the behavior of the CNC machine.

The following machine lines have 
unique colors:

• Tie lines - magenta
• Sequencing lines - green
• Guide Lines - red

Tie lines
Tie lines are colored magenta. Tie 
lines guide the CNC machine from 
object to object in a pattern, with the 
router head removed from the 
workpiece. Without tie lines, the 
robot does not know how to travel to 
the next section of a pattern to 
begin cutting.

The default tie line is a “no cut” line. 
That is, the robot lifts the router 
head our of the work before 
travelling to the next item to be cut.

Creating Tie Lines
Machining > Tie Line ties separate 
objects together to make them one 
object. Tie lines run from the end of 
one object to the beginning of 
another. Objects are tied together in 
sequence, either the order in which 
they were drawn, or the order in 
which they were sequenced.

The objects remain in their original 
location. Figure 5.5 shows two 
objects connected with tie lines. 
The arrows in the figure indicate the 

order and direction in which the 
objects were drawn.

Figure 5.5  Tie lines

The function ties only selected 
objects. If no objects are selected, 
this function draws tie lines between 
all objects in the order in which they 
were drawn or sequenced.

To use the Machining > Tie Line 
function:

• Select the lines or objects you 
want to connect with a straight 
line.

• Select Machining > Tie Line.

The program draws a tie line 
between the objects. 

Connected objects (Tie line)

Seperate objects

1 2
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Untie
Machining > Untie removes tie 
lines between selected objects, or 
all tie lines if no objects are 
selected.

Loop Line
Machining > Loop creates a tie 
line from the last point in the pattern 
to the CNC machine’s starting 
position.

The machine follows this line from 
the end of the pattern to the robot’s 
starting position. Use this function 
when you want the machine to 
return to its starting position after 
cutting an item or a group of items 
for repeated cutting of production 
parts.

Note
If all lines of a pattern are not tied 
together, the loop line may not 
appear to return to the beginning 
of the pattern. However, the 
machine returns to its starting 
position.

Note
If all the lines of a pattern are not 
tied together, the loop line may not 
appear to return to the beginning 
of the pattern. The CNC machine 
arm, however, returns to its 
starting position. 

Sequencing lines
Green lines are used in the 
sequencing process to indicate 
when a line has been selected for 
sequencing. The CNC machine 
cuts objects in sequence order. The 
first drawn object is the first in the 
sequence, the second drawn object 
is next, and so on.

Sequencing allows you to chance 
the sequence order of objects in a 
pattern

Sequencing Objects
Machining > Sequence allows you 
to change the sequence order of 
objects.

As objects are drawn in a pattern, 
they are put in a sequence that the 
machine uses when cutting the 
pattern. Normally, this is the order in 
which the objects were drawn. 
Thus, the first object drawn is the 
first cut by the robot. The second 
object drawn is the second cut.

Machining > Sequence allows you 
to rearrange the sequence of the 
objects for more efficient cutting. 
This allows you to ignore cutting 
sequences until you have 
completed the pattern.

You may sequence all objects in a 
pattern or only those you select.

To sequence all objects in a pattern:
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Deselect all objects you want to 
sequence.

• Select Machining > Sequence.
• Select each object in the order in 

which you want it to be cut.
• Cancel to complete the operation 

when all items in the pattern have 
been selected.

Note
If for some reason you fail to 
select all objects in the pattern, the 
unselected objects are be cut in 
their original order after the 
sequenced items.

Selected Sequencing
You may want to set the sequence 
for only a portion of a pattern. To do 
this:

• Deselect all objects.
• Select the ejects you want to 

sequence. (Their lines turn blue.)
• Select Machining > Sequence.
• Select each of the active objects 

in the order in which you want 
them to be sequenced.
(Their lines turn green.)

• Cancel to complete the 
operation.

These objects now have their own 
order within the overall sequence of 
the entire drawing. Their order 
begins with the first item 
sequenced.

Example: Take a drawing with four 
items, A, B, C, D.

A is the first item drawn, B the 
second, C the third and D the last. 
They would normally be cut in the 
order A, B, C, D.

Instead, you want to cut them in the 
order A, C, B, D, reversing the order 
of B and C, but keeping A and D in 
the original order. 

To select this sequence; 

• Select items B and C; 
• Select Machining > Sequence.
• Select item C, then item B; 
• Cancel to complete the 

operation.

You have reversed the order of 
items B and C without changing 
the order of items A and D.

Figure 5.6  Selected sequencing 

1st cut  2nd cut  3rd cut  4th cut

1st cut  3rd cut  2nd cut  4th cut

Before sequencing

After sequencing

A            B            C             D

A            B            C             D
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Selecting lines
You can select lines by clicking on 
them with the selection cursor and 
the left mouse button. As you 
select each line, all other lines 
become automatically deselected. 

You can select more than one line 
at a time by holding the shift key 
and selecting the lines you wish. 
You can also deselect lines in the 
same manner. 

You may wish to select a single 
vector instead of an entire line. To 
do this, hold the left mouse button 
and drag the cursor to produce a 
selection box around the vector you 
wish to select. Release the button 
to select the vector. 

Note
Only a portion of a vector needs to 
be encompassed by the selection 
box for the entire vector to be 
selected. This method can be 
used to select a large group of 
lines or vectors. Simply drag the 
selection box around the lines you 
wish to select. 

Beginning and ending points
Lines created in the Pattern Maker 
software have a beginning and an 
end. When the CNC machine is 
cutting a pattern, it follows each line 
from beginning to end.

A line begins where you select the 
first point on the workspace. It ends 
where you complete the drawing 
operation by selecting the final 
point.

The endpoint of a line can be 
marked by a small square point 
called a handle which can be turned 
on or off by pressing the H key. The 
beginning of a line has no point. 
Figure 5.7 shows a line and handle.

Figure 5.7  Typical line with a 
handle

If you begin drawing a line with a 
selected object on the workspace, 
the last point of that object becomes 
the first point of the line. In effect, 
this means a newly drawn line or 
object attaches itself to the last 
selected point on the workspace.

Maxym Bar and Pre-Defined 
Settings

Overview
The lines in a pattern tell the CNC 
machine which direction to move in 
two dimensions, the X and Y axes.
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The CNC machine also needs 
instructions for how fast (speed) 
and how deep to cut (Z-depth).

These parameters and several 
others are entered in the Maxym 
bar and the Pre-Defined dialog box 
accessed through the Pre-Defined 
button on the Maxym bar.

Maxym bar
The Maxym bar is located on the 
bottom of the workspace window. 
This bar displays the current line 
properties for new objects.

The line properties include the z 
depth of the cut, the speed of the 
machine (in inches per minute), the 
screen display line style, the type of 
line and any I/O auxiliary settings.

For information on line type, refer to 
Line types on page 52.

For information on I/O settings, 
refer to I/O controllers on page 55. 

Any new objects made with the 
drawing tools have the properties 
shown in this menu. The Maxym 
bar is shown in Figure 2.1.

Pre-defined lines button
Selecting the Pre-Defined button in 
the Maxym bar opens the 
Pre-Defined dialog box for 
user-created lines. In this menu you 
may enter the properties for up to 

five different line types. The 
Pre-Defined menu is shown in 
Figure 5.8.

With this menu open, you can also 
change the current line used in the 
Maxym bar, either by selecting a 
stored line type, or by entering new 
parameters.
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Figure 5.8  Pre-defined line dialog box

Machine lines button
Selecting the Machine Lines 
button in the Maxym bar opens the 
special lines dialog box for the three 
stored machine line types - tie lines, 
loop lines and lead-in lines.

In this box you may set the speed 
and any I/O auxiliary settings for the 
three line types, as well as the 
lead-in coordinate for the lead-in 
line.

The special lines dialog box is 
shown in Figure 5.9.

Figure 5.9  Special lines dialog box

Lead-in Line
The lead-in line instructs the CNC 
machine how to move from the 
machine starting point to the first 
object start point. Enter the point for 
the machine to start under the 
Machine lines button in the 
Maxym bar.
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Vector properties
The information cursor found in 
the drawing tools window (see 
Figure 3.4) allows you to view 
information about, or modify object 
vectors.

The cursor opens the vector 
information dialog box when it is 
used to select an object.

The cursor opens the modify vector 
properties dialog box when it is 
used to select on object while 
holding the ctrl key. 

The information cursor is described 
in detail in Information cursor on 
page 16.

Parameters for the current line 
displayed in the Maxym bar are 
erased and replaced with those of a 
stored line if you open the modify 
vector properties dialog box.

Setting a line pattern
The properties for a line may be set 
in several places.

Setting the current line
Set the properties for the current 
line in the Maxym bar.

Setting stored lines
Set the properties for stored lines in 
the Pre-Defined dialog box, 
accessed through the Pre-Defined 
button on the Maxym bar. Stored 

lines allow you to quickly change 
the current line by simply selecting 
the line type icon in the settings bar.

Changing existing lines
Change the properties of existing 
lines using the information cursor. 
See Modifying object vector 
properties on page 16.

Z-depth setting
Z-depth is the distance the CNC 
machine head travels in the Z-axis - 
the 3rd dimension.

Z-depth is always a positive number 
measured downward from the 
starting position of the CNC 
machine tool. 

For example: Assume the CNC 
machine tool is positioned a 
half-inch above a board. A Z-depth 
value of 1 inch causes the tool to 
drop 1/2-inch to the surface of the 
board, then plunge another 1/2-inch 
into the board. See Figure 5.10. 

Figure 5.10  Z-depth plunge

1/2" 1"1/2"
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The Z-depth can be set from 0 - 60 
inches.*

Note
 *Z-depth capabilities vary with 
different models of CNC 
machines.

Speed
The speed parameter controls the 
rate at which the CNC machine arm 
moves over the workpiece. It is 
measured in inches per minute and 
can be set between 1 and 100.

Line types

Eight different types of lines are 
listed in the line type pull down 
menu in the Pre-defined line dialog 
box and the Maxym bar:

• Flatwork
• 2nd Z flatwork
• X contour
• Y contour
• XY 4th
• 2nd Z 3D
• 3D
• Guide
Each line type gives you a different 
way to control the CNC machine 
arm. 

Flatwork line
The flatwork line indicates 
two-dimensional movement over 
the surface of the workpiece. The 
CNC machine arm follows the 
pattern in the X and Y axes. This 
line is usually used for cutting 
shapes from flat material.

When interpreting a flatwork line, 
the CNC machine arm first performs 
any Z-depth instructions attached to 
the line. 

2nd Z flatwork line
The 2nd Z flatwork line works the 
same as the flat work line, in that it 
performs any Z motion first, then 
follows the pattern in the X and 
Y-axis. The difference is that the Z 
motion is performed on the 4th axis 
when supplied as a second Z-axis.

When the 4th axis is supplied as a 
rotation the Z value rotates the 4th 
axis at a rate of 20 inches of Z for 
360 degrees.

X and Y contour lines
The X and Y contour lines are 
usually used for cutting 
three-dimensional shapes using a 
series of contours. These lines 
instruct the CNC machine to 
interpret the X (X-contour) or Y 
(Y-contour) coordinates in a line as 
Z-axis instructions.
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A CNC machine arm following a X 
contour line travels in the Y-axis, 
while the X coordinates controll the 
Z movement of the CNC machine 
head.

Figure 5.11 shows movement of the 
CNC machine arm while following 
an X-contour line. The X-axis 
coordinates are interpreted by the 
CNC machine as Z-depth 
instructions, causing the head to 
move up and down while moving in 
the Y-axis. 

A CNC machine arm following an Y 
contour line travels in the X-axis 
(side to side), while the CNC 
machine head travels up and down 
in the Z-axis, following the Y 
coordinates.

Figure 5.12 shows movement of the 
CNC machine arm while following a 
Y-contour line. The X-axis 
coordinates are interpreted by the 
CNC machine as Z-depth 
instructions, causing the head to 
move up and down while moving in 
the X-axis.

In both cases, Z-depth information 
in the line is ignored by the CNC 
machine. 

Figure 5.11  X-contour line motion

Figure 5.12  Y-contour line motion
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XY 4th line
The XY 4th line sends Z-depth 
movement instructions to the 4th 
axis motor while the CNC machine 
arm moves along the X and Y axes.

When the 4th axis is supplied as a 
second Z-axis it performs its motion 
the same as 3D line but on the 
second Z. When supplied as a 
rotation, the 4th axis rotates at a 
constant rate as the CNC machine 
arm moves along the X and Y-axis.

The amount of rotation is controlled 
by the Z-depth value. The ratio of 
Z-depth to rotation is set at 20 to 1. 
This means that for every 20 inches 
of Z- depth the 4th axis motor 
rotates 360 degrees. 

(like 2nd z 3d, allows you to set 
rotation scales, rotary- designed to 
operate the rotary 4th axis).

3D lines
The 3D line causes the Z-depth 
position of the CNC machine head 
to change at a constant rate as it 
moves along an X or Y line. The 
head moves from its current 
position at the beginning of the line 
to the new Z-depth position at the 
end, creating a constant slope in 
the workpiece.

For example:

The CNC machine tool is 1 inch into 
the workpiece when the CNC 
machine encounters a 3D line with 
a Z-depth value of 1/2-inch. As the 
CNC machine follows that line, it 
gradually moves the head to the 
1/2-inch Z-depth value. At the end 
of the line, the CNC machine head 
will be at the 1/2-inch level. The 
resulting cut will be sloped. This line 
works in both the X and Y axes. 

Figure 5.13 shows movement of the 
CNC machine arm while following a 
3D line. 

Figure 5.13  3D line motion

2nd Z 3D line
The 2nd Z 3d line works the same 
as 3D line , but on another spindle.
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Guide lines
Guide lines are used as a drawing 
aid to help create patterns. They 
are not interpreted by the CNC 
machine.

Figure 5.14 shows a guide line 
being used as a bounding box. 
Guide lines appear as red lines 
(even when deselected) in the 
workspace window.

Figure 5.14  Guide lines

I/O controllers
You can attach and control up to 
four auxiliary motors or devices 
through the CNC machine and 
Pattern Maker software. One of 
these devices is usually the router 
mounted on the CNC machine 
head. The remaining three can be 
air compressors, vacuums, etc.

The devices are plugged into the 
I/O box on the CNC machine and 

controlled by selecting the I/O 
control button, then by clicking on 
the numbered buttons in the 
auxiliary I/O settings dialog box.

The I/O control button is located in 
the the Maxym bar, the Pre-Defined 
dialog box accessed through the 
Pre-Defined button on the Maxym 
bar, and in the Modify Vector 
Properties dialog box accessed 
through the information cursor.

The auxiliary control menu is shown 
in Figure 5.15. A checked box 
indicates the device is on, an 
unchecked box indicates off. 

Figure 5.15  Auxiliary control menu

Tool compensate

Machining > Tool Compensate 
adjusts the pattern to account for 
the diameter of the cutting tool.
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Overview

This chapter describes how to load 
and save files to and from the 
workspace, and explains the 
different kinds of files used by the 
Pattern Maker software.

This chapter also discusses how 
patterns created in other design 
programs may be used by the 
Pattern Maker software and Maxym 
CNC machine. 

The file menu

The File menu allows you to 
perform the following tasks to 
manage your files:

New (ctrl-n)
File > New creates a new pattern 
file with an empty workspace.

The default name for a new pattern 
file is Pattern1.pmf (with the number 
increasing if a file with the same 
name is currently open).

You may create a new pattern at 
any time without closing or saving 
other open patterns. Windows 
allows you to work on multiple files 
at the same time.

Open (ctrl-o)
File > Open opens a pattern file 
from a disk.

Close
File > Close closes the current 
pattern file and removes it from the 
screen. If you have not saved the 
current version of the file, you will 
be prompted to do so before the file 
closes.

Save (ctrl-s)
File > Save writes the pattern to a 
file. The first time you save a file, a 
Windows dialog box opens. In this 
box, choose the file name, file type 
and directory to store the file.

Following the first save of an open 
pattern file, each time you select 
File > Save, the current pattern 
rewrites the previously saved 
version without asking you for a 
name.

Note
If you enter a file name that 
already exists in that directory, 
Windows will ask if you want to 
replace the existing file. If you 
choose "yes", the existing file is 
replaced by the new pattern file. If 
you choose "no", the save 
operation is canceled.

Save As
File > Save As opens the Windows 
save box each time, allowing you to 
change the file name, file type and 
directory of the current pattern.
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Use the File > Save As function to 
export files as different file types. 
See Supported file types on page 
58 for a complete description of the 
file types.

Print (ctrl-p)
File > Print prints the pattern to 
your printer. The entire pattern 
prints on a single page.

Print Preview
File > Print Preview displays on 
the screen how the pattern will 
appear printed on a piece of paper.

Print Setup
File > Print Setup allows you to 
adjust your printer settings.

Exit
File > Exit closes the Pattern Maker 
program. If you have any open 
patterns with changes that have not 
been saved, you will be prompted to 
do so before the program closes.

Supported file types

The Pattern Maker software can 
open the following file types:

• Patter Maker files (.pmf)
• Output files (.pat)
• G-code files (.nc)

Note
When opening G-code (.nc) files, 
refer to Loading G code files on 
page 58

• DXF Files (.dxf)
• CPattern View files

Pattern Maker files (.pmf)
These are the native files for 
drawing from the current release of 
the Pattern Maker software.

OutPut file (.pat)
These are the native files for 
drawings from previous Pattern 
Maker software releases. Also 
referred to as PATTERN files.

G-Code (.nc)
These are CNC machine motion 
files from CAM programs.

Loading G code files
To load a G Code file into Pattern 
Maker, the file must first have the 
extension ".nc". If the CAD-CAM 
program uses a different file 
extension you can rename the file.
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Note
To rename a file in Windows, click 
the right mouse button on the file 
name in the file list and choose 
“rename”.

G-code patterns loads into Pattern 
Maker at 0.0X, 48.0Y, which is in 
the lower left side of the drawing 
world. 

If the G-Code file contains negative 
coordinates, all coordinates are 
offset into positive X,Y coordinate 
space in Pattern Maker, the Z data 
is also inverted to most CAD-CAM 
systems. In the CAD-CAM system 
the zero position is the top of the 
part and positive Z raises the Tool. 
When reading the Z data Pattern 
Maker take the highest tool position 
and converts it to zero, with positive 
Z data going down into the work.

The G codes that Pattern Maker 
can convert are listed below. This 
section also describes how Pattern 
Maker interprets the code. Mode 
control words remain in effect until a 
new mode control word is read.

• G90 Absolute Mode: Absolute 
positive or negative coordinates 
offset to positive

• G91 Incremental Mode: Relative 
positive or negative coordinates 
converted and offset into positive 
absolute.

• G00 Positioning Mode: 
Converted to Tie Line

• G01 Linear Interpolation: 
Converted to 3D line

• G02 Clockwise Arc
• G03 Counter Clockwise Arc

Arc Conversion:
 
Absolute: G90 G02 X_Y_Z_I_J_

Absolute positions for both arc 
end point words X,Y,Z and arc 
center words I, J. 

Incremental: G91 G02 
X_Y_Z_I_J_
Incremental positions for both arc 
end point words X,Y,Z and arc 
center words I, J.

Arcs are converted to a series of 
straight 3D Lines based on the 
settings of the Circle Sides and 
Circle Type system variables.

Program Words:

X = X Axis Position inches
Y = Y Axis Position inches
Z = Z Axis Position inches
I = X Axis Arc Center inches
J = Y Axis Arc Center inches
F = Feed-rate inches/min.

The feed-rate program word 
remains in effect until a new 
feed-rate word is read. 
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Note
G00 Positioning mode is always 
the speed of the tie line. Each line 
in the file can not contain more 
than one move for each axis. 

DXF (.DXF)
These are drawings to or from other 
CAD or drawing programs.

There may be times when you want 
to use the Maxym CNC machine to 
create a product designed on a 
program other than the Pattern 
Maker software. This is possible 
through the use of DXF files

A DXF file contains only the vectors 
of a drawing. These vectors do not 
have any Pattern Maker line 
parameters (such as speed or line 
type) attached to them. They do, 
however, retain their individual 
identities in the form of a "color 
number." 

DXF is a universal file format 
created in a Computer Assisted 
Drawing (CAD) or similar program. 
These files are designed to be used 
by many different kinds of 
programs, including the Pattern 
Maker software. 

Thus, if a drawing contained three 
different styles or colors of lines, 

each line is identified by a different 
number in the DXF file. 

When the DXF file is loaded into the 
Pattern Maker program, the file is 
converted into a format the Pattern 
Maker program can use. During this 
process, the different lines in the 
DXF file are assigned Pattern 
Maker line parameters based upon 
existing line parameters in the 
Maxym line menu.

Like G-code files, Pattern Maker 
assigns the DXF pattern origin point 
to (0, 48) when loading.

Lines are assigned parameters 
beginning with the current line bar 
and working up the Maxym line 
menu. Thus, a line identified by 
color number 1 would be assigned 
the parameters in the current line 
bar. A line identified by color 
number 2 would be assigned the 
parameters at the bottom of the 
Maxym line menu. 

If there are more DXF lines than 
styles in the Maxym line menu, the 
remaining lines are assigned the 
parameters from the current line 
menu. 

This also happens if there are no 
color numbers assigned to the lines 
in the DXF file. In this case, all the 
lines in the DXF files are assigned 
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the parameters in the current line 
bar. 

Arcs and circles in DXF and G 
code files
Both the DXF and G Code files 
store arcs and circles separately 
from lines. Pattern Maker converts 
these to a series of straight lines 
based on the settings of Circle 
Sides and Circle Type system 
variables. See Circle settings - by 
angle or length on page 22. 

Note
When there is a large variety of 
arc sizes, sometimes setting the 
Circle Type variable to Length 
produces better results. 
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Overview

This chapter is designed to help you 
use the CNC machine efficiently. It 
discusses the correct way to 
position the CNC machine arm 
before cutting a pattern, some 
methods for laying out a series of 
patterns so that they can be cut 
from a single sheet of stock, and 
methods of clamping stock to the 
CNC machine worktable. 

Positioning the CNC machine 
arm 

Before a pattern can be cut with the 
CNC machine arm, the arm must be 
positioned properly. This is because 
the CNC machine does not have 
any knowledge of its position on the 
workspace. It follows only the 
directions in the patterns stored in 
its memory. 

When a pattern is downloaded to 
the CNC machine, the CNC 
machine begins work on the pattern 
wherever the arm happens to be 
sitting at the time.

Thus, if the CNC machine arm is 
positioned over the middle of the 
worktable, it begins cutting a pattern 
at that point - even if you want the 
pattern to start in the corner of your 
stock. 

There are two ways to insure the 
CNC machine arm is positioned 
properly before beginning a pattern: 

• Return the CNC machine arm to 
the home position and use a 
"lead-in" pattern to guide the 
CNC machine to the starting 
point. 

The second option requires you to 
draw two lines to guide the CNC 
machine from its home position to 
its starting position over the 
workpiece. 

This pattern consists of two lines. 
The first is a "lead-in" line that 
begins at absolute zero and 
connects to the pattern's starting 
point. This line is normally a "no cut" 
flatwork line. 

The second line is a Y-contour line 
that is sequenced after the "lead-in" 
line. This line moves the CNC 
machine's Z-head to the proper 
height above the first point of the 
pattern.

Figure 7.1 shows a pattern with a 
lead-in line.

Figure 7.1  A pattern with a lead-in 
line
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Setting the starting depth
The Z-depth values in a pattern 
assume that the CNC machine arm 
will begin cutting from a certain 
height above the workpiece. In 
order to cut the pattern properly, the 
CNC machine tool must be 
positioned at the proper height 
above the workpiece before the 
pattern is downloaded to the CNC 
machine.

Example:

Assume you are cutting through a 
piece of 1/2-inch stock. You know 
the Z-depth of the pattern lines is 1 
inch. If you position the CNC 
machine tool at .4 inch above the 
workpiece, the CNC machine tool 
will be able to cut through the 
material with .1 inch to spare.

Organizing your work

Pattern layout
When cutting many copies of a 
pattern from a sheet of flat stock, it 
is usually most efficient to cut an 
entire sheet of patterns at once. 

To do this, you need to make copies 
of the pattern and lay them out on 
the workspace in a series of 
columns or rows. 

It is helpful first to draw a bounding 
box on the workspace the same 
size as your stock. Then, by using 

the copy function, you can copy and 
place the patterns in a column or 
raw within the bounding box.

Note
Use a guideline to draw the 
bounding box.

Figure 7.2  Items within a bounding 
box

Efficient layout
There are several methods for 
laying out a sheet of patterns. One 
is to use the workspace grid as a 
guide. 

To do this: 

• Draw a box that represents the 
boundaries of your stock.

• Place your original pattern in the 
upper left- hand corner of the box. 
Be sure to leave enough space 
along the edge to accommodate 
whatever clamping method you 
will be using.
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• Measure the width of the pattern. 
Then set the drawing grid to a 
slightly larger size

• Make sure the entire pattern is 
selected. Then select Edit > 
Copy.

Note
Make sure you have tied together 
all the elements that need to be 
tied before copying the original 
pattern.

• Place the cursor on the first point 
of the pattern. Then press the 
right keyboard arrow to move the 
cursor to the next grid space. 
Repeat until you are just beyond 
the pattern

• Edit > Paste to place a copy of 
the pattern in the workspace. The 
copy should appear in alignment 
with the original. 

You can repeat this action, using 
the arrow key to move at regular 
intervals across the workspace. 
When you reach the end, you 
should have a row of patterns. 

When you come to the edge of the 
bounding box, you have two 
options: 

You can move the cursor down and 
repeat the process you just 
completed. 

Or, you can select the entire row of 
patterns, copy it and place it just 
below the top row.

When you have filled the bounding 
box with patterns, you need to tie 
everything together. To do this, 
make sure all the patterns are 
selected, then select Machining > 
Tie Line. This creates a tie line that 
guides the CNC machine arm from 
pattern to pattern.

You may also want to create a loop 
line (Machining > Loop). This 
guides the CNC machine arm back 
to the beginning of the stock once it 
has cut a complete sheet of 
patterns.
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The following checklist is provided 
to help you make complete pattern 
files.

1. Draw all pattern objects.
2. Verify the Z-depth for all lines.
3. Verify the speed for all lines.
4. Verify the line type for all lines.
5. Create a tie line for the entire 

pattern.
6. Create a loop line if necessary for 

production work. Refer to Loop 
Line on page 46.

7. Enter the lead-in point. (Refer to 
Lead-in Line on page 50.)

8. Set the tool compensation for the 
pattern. Refer to Tool 
compensate on page 55.

9. Save the file.



68686868

MAXYM



AppendicesAppendicesAppendicesAppendices 69696969

MAXYM AppendicesAppendicesAppendicesAppendices

Appendix 1: Cutting tips

CNC machines are versatile and 
can be used in many different 
situations to cut many different 
types of material. Because of this, it 
is difficult to cover every cutting 
situation here completely. 

We have included some basic 
information for selecting router bits 
and choosing cutting speeds as well 
as instructions for certain cutting 
methods and tips. We recommend, 
however, you discuss your 
particular situation with a reputable 
manufacturer of CNC machine bits 
for specific advice. We will also be 
glad to advise you based on the 
experience we have accumulated 
with the Maxym CNC Machine.

Bit selection
While you can use many different 
types of bits with the CNC machine 
router, there are a few 
characteristics to keep in mind 
when choosing your cutting tool.

Bits or end mills should be 
purchased from a dealer who 
specializes in machine tools or CNC 
equipment. In some cases bits may 
be ordered by mail. Onsrud Cutter 
Inc., 800 Liberty Drive, Libertyville, 
IL 60048 (708) 362-1 560 offers a 
full line of CNC machine bits 
through its catalog. The catalog 

also contains many helpful cutting 
hints.

DO NOT USE bits designed for 
woodshop routers with the Maxym 
CNC Machine system.

All bits used with the Maxym CNC 
Machine arm should have cutting 
surfaces on the bottom as well as 
the sides. This allows the bit to 
plunge cleanly into your workpiece. 
We recommend using carbide bits 
because they last longer than 
high-speed steel bits. 

For most flat stock cutting jobs we 
recommend using two-flute spiral 
bits. These bits eject chips upward 
where they can be removed by a 
vacuum attachment.

Because these bits may tend to lift 
the stock off the cutting table, you 
must ensure the workpiece is well 
clamped before you begin cutting. 

If you are using very thin stock, you 
may want to consider using a 
downcut spiral bit. This bit actually 
pushes the stock against the cutting 
table. This bit is not recommended 
for use in thick stock because it 
does not clear chips efficiently. 

In some cases, a straight-edged bit 
may produce a smoother cut. If you 
use a straight-edged bit, however, 
you must reduce the speed of the 
CNC Machine arm to compensate 
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for the slower cutting speed of that 
bit style.

Bit size

The size of the bit depends on the 
thickness of the material you are 
cutting. The cutting edge of the bit 
must be at least as long as the 
stock's thickness. This is true even 
in cases where you may not be able 
to cut the stock in a single pass.

The cutting edge, however, should 
not be significantly longer than the 
thickness of the stock. 

Bits with longer cutting edges have 
a larger diameter than bits with 
short cutting edges. This is 
important to keep in mind when 
designing your pattern. If you will be 
cutting thick stock, your pat- tern 
should be designed to 
accommodate the larger tool 
diameter.

Cutting direction
In most woods, the smoothest cut is 
one made with the arm moving 
against the direction of router 
rotation. Cuts made in the opposite 
direction, called "climb cuts," can 
leave a rough surface behind.

In some cases, you may need to 
reverse the direction of your pattern 
in order to avoid climb cutting.

Feed rates
The rate at which the CNC machine 
can move the cutting router through 
the stock varies depending on bit 
size and type, stock type and 
thickness. 

In general, the bit should be moved 
through the stock fast enough to cut 
its way freely. Moving the tool too 
quickly causes strain and 
deflection. Moving the tool too 
slowly causes friction and burning.

Clamping
USA CNC Machine offers several 
types of clamping equipment to hold 
stock under the CNC machine 
arms.

Worktable
The worktable is a welded steel 
frame with a PVC work surface. 
USA CNC Machine recommends 
using a sheet of MDF wasteboard 
on top of this as a cutting surface.

Your workpiece can be clamped to 
the worktable using any method you 
choose. 

Pressure table
The pressure table uses a vacuum 
created by a high-pressure blower 
to hold the stock. The table comes 
with a machined grid, high-pressure 
blower, electrical switch and 
terminal box. A piece of porous 
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wasteboard is placed on top of the 
table as a cutting surface.

The blower is able to maintain 
adequate pressure even as 
patterns are cut from the stock.

Clamp tables
USA CNC Machine also offers 
clamp tables with two or three 
horizontally positioned air-operated 
clamps. When activated, the 
clamps pin the stock against a fixed 
steel fence. The clamps and fence 
are drilled so that you can attach a 
wasteboard.

Hold-in tabs
If you will be cutting many parts 
from a sheet of stock, you may want 
to use hold-in tabs to prevent 
already cut parts from being ejected 
by the spinning router tool.

Hold-in tabs are designed into the 
pattern by slightly reducing the 
Z-depth values at two or three 
points around the boundary of the 
part. This causes the CNC machine 
to leave a small piece of stock 
holding the part. After the CNC 
machine has completed cutting, the 
parts can be snapped away from 
the stock and trimmed by hand if 
necessary. 

Note
Hold-in tabs are not necessary 
when using a pressure table to 
hold the stock. 

Efficient cutting
In order to increase the efficiency of 
the CNC machine, you may use 
several methods to cut multiple 
copies of a product from a single 
pattern. 

One method is to cut several sheets 
of stock at once. You can do this if 
the stock is thin enough and the 
router tool long enough.

Note
You may need to reduce the 
speed of the CNC machine arm to 
compensate for the extra cutting 
effort.

You can also use more than one 
router head on some CNC 
machines, including Maxym CNC 
machines. USA CNC Machine 
offers an adjustable quick-change 
plate that will hold two router heads. 
This allows you to cut two parts 
while the CNC machine is following 
a single pattern.

When using this arrangement, you 
may need to rethink the layout of 
your patterns on the working 
surface.
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For instance, if you are cutting a 
sheet of parts that were laid out for 
a single router head, you need to 
eliminate every other column of 
patterns to account for the second 
router head.

Cutting with two Z-heads
USA CNC Machine offers the option 
of a second Z-head to the Maxym 
CNC Machine arm. This head is 
controlled in- dependently of the 
first Z-head and can be used to 
mount an air drill or other device.

The second Z-head is controlled 
through the Rotate 4th axis line.

Appendix 2: Troubleshooting

Error messages
When the Pattern Maker software 
encounters an error, it will notify you 
by using an error message dialog 
box. Error messages produced by 
the program are explained below.

File menu
Message: No entities found in DXF 
file

Problem: There is no drawing 
contained in the DXF file you are 
attempting to load. 

Solution: Check the program that 
created the DXF file. 

Message: Error reading DXF file

Problem: The DXF file you are 
attempting to load is corrupted.

Solution: Check the program which 
created the DXF file.
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Numerics
3D shapes 40

A
Absolute coordinates 10
Absolute zero point 8
Appendices 69
Arc 23

By angle or length 24
Arrow cursor 7, 15
Arrow keys 10

B
Backspace 9
Bit selection 69
Bit size 70

C
Cancel command 6
Checklist 67
Circle

By angle 22
By length 22
Circle types 21

Circles 20
Clamp tables 71
Clamping 70
CNC machine 43

Positioning the CNC machine arm
63

Connect 30
Contours 40
Coordinate boxes 10

Entering values 9
Crosshair cursor 8
Cursor lock

X-axis 9
Y-axis 9

Cursors 7
Cutting

Two Z-heads 72
Cutting direction 70
Cutting tips 69

D
Delete 9
Dialog boxes 1
Drawing techniques 35
Drawing tool bar 18
Drawing tools bar 5

E
Efficient cutting 71
Ellipse 24

By angle or length 25

F
Feed rates 70
Figures

3D line motion 54
A pattern with a lead-in line 63
Auxiliary control menu 55
Circle types 21
Coordinate Boxes 11
Flip horizontally 28
Flip vertically 28
Guide lines 55
Items within a bounding box 64
Manipulate Z function 29
Modify vector dialog box 17
Object reference point 25
Parts of an arc 24
Pointer tool bar 15
Pre-defined line dialog box 50
Proportional and disproportional

scaling 34
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Relative zero point marker 8
Screen cursors 7
Selected sequencing 47
Special lines dialog box 50
The connect directly function 31
The connect displaced function 32
The workspace window 4
Tie lines 45
Transformation tool bar 25
Typical line with a handle 48
Using the circle tool 23
Using the ellipse tool 24
Using the line tool 19
Using the move function 33
Using the move point tool 26
Using the rectangle tool 20
Using the right angle line tool 19
Using the rotate tool 27
Using the scale function 34
Vectors 43
X-axis machine movement 44
X-contour line motion 53
Y-axis machine movement 44
Y-contour line motion 53
Z-axis machine movement 44
Z-depth plunge 51

Files
Accessing and managing 57
Supported file types 58

G-code files 58
Output files 58
Pattern maker files 58

Flip 27

G
G-code files 58
Grid 3

Snap 4, 10
Grid size 3

Guide lines 55

H
H key 9
Handles 9
Hold-in tabs 71

I
I/O controllers 55
Information cursor 7, 16
Introduction 1

K
Keyboard 1

Arrow keys 10
Backspace 9
Delete 9
Enter 9
H key 9
Shift key 9
Space bar 8
Tab 9
X key 9
Y-key 9

Keyboard input 8

L
Layers 12
Layout 64
Lead-in carving 41
Lean-in line 50
Line 18
Line colors 11
Line parameters

Changing 37
Line types 43, 52

2nd Z flatwork line 52
3D lines 54
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Flatwork line 52
Guide lines 55
X and Y contour lines 52
XY 4th line 54

Line types2nd Z 3D line 54
Lines

Changing 51
Colors 44
Lead-in 50
Line speed 52
Loop lines 46
Machine lines 50
Pre-defined 49
Selecting a line pattern 51
Tie lines 45

Loop lines 46

M
Machine lines 50
Machine processes 63
Machining 43
Manipulate Z 29
Manual

Getting started 1
Styles 1

Maxym bar 5, 49
Modify vectors 16
Mouse 6

Mouse buttons 6
pan 7
Scroll button 6

Mouse functions 32
Move 32
Move cursor 8
Move point 26
Multiple select 9

N
Numeric coordinates 35

O
Object reference point 25
Objects and Statics 5
Output files 58

P
Pattern layout 64
Pattern maker files 58
Point snap 10
Pointer bar 5
Pointer tool bar 15
Pre-defined lines 49
Pressure table 70

R
Rectangle 20
Relative coordinates 10
Relative zero point 8
Reverse 28
Right angle line 19
Rotate 26
Rotate cursor 8
Rulers 5

S
Scale cursor 8
Scale object 33
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